
<!DOCTYPE html>
<html lang="en" xmlns:og="http://opengraphprotocol.org/schema/">
<head> 
  <link rel="icon" type="image/x-icon" href="http://westernnews.media.clients.ellingtoncms.com/static/custom/kdminer/logos/favicon.ico" sizes="32x32">
  <link rel="icon" type="image/png" href="http://westernnews.media.clients.ellingtoncms.com/static/custom/kdminer/logos/favicon.png" sizes="32x32">
  <meta charset="utf-8">
  <meta http-equiv="Content-Type" content="text/html">
  <title>Just shake my head and move on | Kingman Daily Miner | Kingman, AZ</title>
  
  
  
  <meta property="fb:app_id" content="1377253742291231" />
  <meta property="og:url" content="http://kdminer.com/news/2017/jan/20/just-shake-my-head-and-move/">
  <meta property="og:type" content="article">
  <meta property="og:title" content="Just shake my head and move on">
  <meta name="og:description" content="Sometimes we just have to shake our head and move on.">
  <meta property="og:site_name" content="http://www.kdminer.com" />
   
    <meta name="og:description" content="Sometimes we just have to shake our head and move on. I don&#39;t expect everyone to understand everything, but can&#39;t we at least expect SOME common sense? 

I recently took one of my dogs for his monthly toenail trim. I like to use the vet apposed to a groomer. I have had a few bad experiences with dog groomers. My choice and nothing against groomers. As it turned out, my old dog was injured during the visit. He is 13 years old, and his joints are not in the best condition. Anyway, I ended up needing to get an anti-inflammatory medication for him. I asked the veterinarian to please call in the medication to a pharmacy that I know fills animal prescriptions. They are much cheaper than what the doctor’s office charges.

Having dealt with this pharmacy in the past, I knew it was best to call first and make sure the medicine was called in before trying to pick it up. I was assured that it was ready and could be picked up. I was also happy that it was only $5.03. So, there I am at the counter. I tell them MY name and that the prescription would be for my dog, TIMMY. &quot;I have nothing here for you or Timmy.&quot; I said, “I already called and someone here said you DO have it.&quot; &quot;What is the birth date?&quot; she said. &quot;Mine or Timmy&#39;s?&quot; I asked. &quot;Let&#39;s try both&quot; was her suggestion. Again, I was told she had nothing. I suggested she try checking under the name of the veterinarian. Whoopee! Finally found it.

It turned out that the doctor had given the wrong birth date for Timmy, my dog. I guess it was just easier to say, &quot;We have no medication called in for you.&quot;

Ever have one of those days that it seems anything that you try to do has some kind of glitch? It can start with running out of coffee when you are ready to make that needed eye-opener in the morning. Myself, I would never let that happen. I might run out of many things, but toilet tissue or coffee, never gonna happen.It could start with finding that one of the dogs has left you a package in a corner. You may discover it after you have already stepped in it. Why is it so darn hard to clean dog poop off the bottom of a slipper? Maybe you left a couple of small throw rugs to dry outside. It sure didn&#39;t LOOK like rain. It is a lot like spending an hour sweeping up all the leaves from your front patio, and then twenty minutes later you see that the wind has blown a thousand more leaves in, from the neighbors who were obviously smart enough to wait on the sweeping.

How about when you finally decide to hang up those framed photos you have had stuck in the closet since you last moved. (Yes, it could be over two years. I don&#39;t judge.) You are careful to find the perfect-sized nail to accommodate what you are going to hang. You put the picture up and step back to look at your work. Low and behold, it is crooked! I can&#39;t live with crooked! So, you decide to start over. During this process, you drop the nail on the floor. Even with a flashlight, you are unable to find the nail! You immediately decide that if you don&#39;t find it, one of your dogs will step on it and it will go directly into their foot. After twenty minutes, you finally give up and just pray for the dogs.

I can&#39;t be the only one who gets all the upsetting mail on Saturday. You know the kind I mean. The insurance company mail that says you owe much more than you KNOW that you owe? Or the one that says they &quot;did not receive your payment&quot; and you know that is crap! Or your electric bill shows up and it is twice what you figured it would be. I have to wonder how they do it? How do they know exactly when to mail it that will have it show up on Saturday? Thus allowing you to stew about it until Monday, when you probably can&#39;t get through on the phone anyway.

OK. Who has NOT ever left the front door key in the lock? You are bringing in a bunch of groceries, and manage to open the door without having to set bags on the ground. You shut the door behind you and hurry to get the freezer stuff put away. After everything is put where it belongs you take a few minutes to relax and are glad that is over with for a week. When you go to bed that night you check that the front door is secured to insure that no one can come in and harm you. When you go out in the morning to pick up your morning paper, guess what? Your house key is securely hanging from the lock! An invitation to enter without breaking in. And yet, you slept like a baby, knowing you were all safe and sound.

I was recently shopping at a retail store here in town for a new outfit for my birthday. I was happy to find just the outfit I wanted. I looked for a check out that had less than ten people in line. I assured the person who took me shopping that I would get in and out quick. Once again I had one of those little glitches. The cash register in MY line had a problem with its computer. Everyone in line was asked to step into yet another line. As the person at the head of the line got his items totaled up, this register ALSO had a problem with the computer. When we were asked to move again, I had about had enough! Does it not occur to anyone yet that the registers all work from the SAME computer system? Hello!

Filling up pill containers can be another test of patience. Especially if any of your medications include tiny pills. When your hands are the size of boxing gloves, close work is always a challenge to begin with. You have all the medicines in a large box. You put the box with the bottles on the kitchen table. I personally have not only my medications, but Sister&#39;s as well. I line up the weekly morning/evening containers and I am ready. I have been doing this for so long, it SHOULD be easy. Not! If I don&#39;t knock at least one of the filled containers over, I am almost guaranteed to drop at least one pill on the floor! This can often put me into panic mode. Again, I not only have two tiny dogs that one of which will eat ANYTHING off the floor, but a two-year-old great-granddaughter who cannot be totally trusted yet. If I have done this once, I have done it ten times. I look for the pill that I have dropped. I know it hit the floor, because I heard it. How does it bounce and end up in another room all together? I have had occasion to ask my neighbor who has much better eyes than I to please come and help me look for the pill.

These are just a few of the things that I experience on a fairly regular basis. Please tell me I am not the only one who has days when NOTHING goes as planned. It is these little glitches that make some people drink wine, I think.

As for yours truly, I just shake my head and move on..">
   
  
  <meta property="og:image" content="http://westernnews.media.clients.ellingtoncms.com/img/photos/2016/08/26/KDM-Linda-Varon-older-than-dirt-blog-thumbnail.jpg" />
  
  <meta property="og:site_name" content="kdminer">
  <meta name="twitter:title" content="Just shake my head and move on">
  
  <meta name="twitter:card" content="summary_large_image">
  <meta name="twitter:site" content="@kdminer.com">
  <meta name="twitter:image" content="http://westernnews.media.clients.ellingtoncms.com/img/photos/2016/08/26/KDM-Linda-Varon-older-than-dirt-blog-thumbnail.jpg">
  
  
  <meta name="twitter:description" content="">
  
  <meta name="twitter:widgets:csp" content="on">

  
  
  <link rel="stylesheet" href="http://westernnews.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/min.css?v=11" type="text/css" media="screen, print">
  <link rel="stylesheet" href="http://westernnews.media.clients.ellingtoncms.com/static/custom/print.css?v=10" type="text/css" media="print">
  
  <!--[if IE 6]><link rel="stylesheet" href="http://westernnews.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/stylesheets/ie6.css" type="text/css" media="screen"><![endif]-->
  <!--[if IE 7]><link rel="stylesheet" href="http://westernnews.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/stylesheets/ie7.css" type="text/css" media="screen"><![endif]-->
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.6.1/css/font-awesome.min.css">
  <link rel="stylesheet" href="http://westernnews.media.clients.ellingtoncms.com/static/custom/westernnews_base.css?v=106" type="text/css">
  
  <link rel="icon" type="image/x-icon" href="http://westernnews.media.clients.ellingtoncms.com/static/custom/kdminer/logos/favicon.ico" sizes="32x32">
  <link rel="icon" type="image/png" href="http://westernnews.media.clients.ellingtoncms.com/static/custom/kdminer/logos/favicon.png" sizes="32x32">
<link rel="stylesheet" href="http://westernnews.media.clients.ellingtoncms.com/static/custom/dcourier/jquery-ui-1.11.4.custom/jquery-ui.theme.min.css?v=5" type="text/css">
<link rel="stylesheet" href="http://westernnews.media.clients.ellingtoncms.com/static/custom/bxslider-4/dist/jquery.bxslider.min.css" type="text/css?v=24">
<link rel="stylesheet" href="http://westernnews.media.clients.ellingtoncms.com/static/custom/kdminer/style.css?v=27" type="text/css">

  <script type="text/javascript">
    var STATIC_MEDIA_URL = 'http://westernnews.media.clients.ellingtoncms.com/static/';
  </script>
<script type="text/javascript" src="http://westernnews.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/javascript/lib/cookies.js"></script>
<script type="text/javascript" src="http://westernnews.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/javascript/lib/mobile_detect.js"></script>
<script>
   var cookie_value = Ellington.Cookies.get_cookie('template_preference');
      if (cookie_value === null) {
        if (Ellington.TabletDetect()) {
          Ellington.Cookies.set_cookie('template_preference', 'mobile');
          window.location.reload(true);
        }
        if (Ellington.MobileDetect()) {
          Ellington.Cookies.set_cookie('template_preference', 'mobile');
          window.location.reload(true);
        }
      } else if (cookie_value == 'mobile' || cookie_value == 'tablet') {
        if (window.location.host == "www.kdminer.com" || window.location.host == "kdminer.com") {
    window.location.search='?templates=mobile';
          window.location.reload(true);
        }
      }
</script>
  <script type="text/javascript" src="http://google.com/maps/api/js?sensor=true" ></script>
  <script type="text/javascript" src="http://westernnews.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/min.js?v=4"></script>
  
  <script type="text/javascript" src="http://westernnews.media.clients.ellingtoncms.com/static/javascript/linkify.min.js" async></script>
  <script type="text/javascript" src="http://westernnews.media.clients.ellingtoncms.com/static/javascript/linkify-jquery.min.js" async></script>
  
  <link type="application/rss+xml" rel="alternate" href="/rss/comments/objects/155/73107/">

  <meta name="viewport" content="width=1020">
  
  <script type='text/javascript'>
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') +
        '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
    })();
  </script>

    
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/132810331/dm_wp', [1, 1], 'div-gpt-ad-1469733588274-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>



 <script type='text/javascript'>      
    googletag.cmd.push(function() {
    googletag.defineSlot('/132810331/dm_obit_rr1', [[300, 250], [300, 600]], 'div-gpt-ad-1467835314042-0').addService(googletag.pubads()).setCollapseEmptyDiv(true);
    googletag.defineSlot('/132810331/dm_obit_rr2', [[300, 250], [300, 600]], 'div-gpt-ad-1467835314042-1').addService(googletag.pubads()).setCollapseEmptyDiv(true);
    googletag.defineSlot('/132810331/dm_obit_rr3', [[300, 250], [300, 600]], 'div-gpt-ad-1467835314042-2').addService(googletag.pubads()).setCollapseEmptyDiv(true);
    googletag.defineSlot('/132810331/dm_ict', [[160, 600], [300, 250]], 'div-gpt-ad-1469119880082-0').addService(googletag.pubads());
    googletag.defineSlot('/132810331/dm_lb_atf', [[970, 60], [728, 90], [728, 250], [970, 250], [970, 90], [989, 150]], 'div-gpt-ad-1478281167011-0').addService(googletag.pubads());
    googletag.defineSlot('/132810331/dm_lb_btf', [[728, 90], [989, 150], [728, 250]], 'div-gpt-ad-1478281167011-1').addService(googletag.pubads());
    googletag.defineSlot('/132810331/dm_non_rotating', [[300, 100], [300, 50]], 'div-gpt-ad-1478281167011-2').addService(googletag.pubads()).setCollapseEmptyDiv(true);
    googletag.defineSlot('/132810331/dm_non_rotating2', [[300, 100], [300, 50]], 'div-gpt-ad-1478281167011-3').addService(googletag.pubads()).setCollapseEmptyDiv(true);
    googletag.defineSlot('/132810331/dm_non_rotating3', [[300, 100], [300, 50]], 'div-gpt-ad-1478281167011-4').addService(googletag.pubads()).setCollapseEmptyDiv(true);
    googletag.defineSlot('/132810331/dm_non_rotating4', [[300, 50], [300, 100]], 'div-gpt-ad-1479510255151-0').addService(googletag.pubads()).setCollapseEmptyDiv(true);
    googletag.defineSlot('/132810331/dm_non_rotating_5', [[300, 50], [300, 100]], 'div-gpt-ad-1479510255151-1').addService(googletag.pubads()).setCollapseEmptyDiv(true);
    googletag.defineSlot('/132810331/dm_rr_1', [[300, 600], [300, 250]], 'div-gpt-ad-1469119880082-9').addService(googletag.pubads());
    googletag.defineSlot('/132810331/dm_rr_2', [[300, 600], [300, 250]], 'div-gpt-ad-1469119880082-10').addService(googletag.pubads());
    googletag.defineSlot('/132810331/dm_rr_3', [[300, 600], [300, 250]], 'div-gpt-ad-1469119880082-11').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
  </script>



</head>
<body class="news story_detail revision" id="story_73107">
  <script>
    dataLayer = [];
  </script>


    
      
          
            <script>
            var re = /(?!.*\/).*/i;
            var category = '[News] /Features'.match(re)[0];
            dataLayer.push({
              'contentGroup1': category,
              'dimension1': category
            });
            </script>
          
      
    
      
    



<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TS4BNC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-TS4BNC');</script>
<!-- End Google Tag Manager -->
 

  


<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '1377253742291231',
      xfbml      : true,
      version    : 'v2.7'
    });
  };
  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>


    
<!-- /132810331/dm_wp -->
<div id='div-gpt-ad-1469733588274-0' style='height:1px; width:1px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469733588274-0'); });
</script>
</div>


<div id="page">

  
<!-- /132810331/dm_lb_atf -->
<div id='div-gpt-ad-1478281167011-0' style="display:block; margin:0 auto; text-align:center;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1478281167011-0'); });
</script>
</div>

  
  <div id="toolbar">
    <div class="wrapper">
      
        
          <ul>
            <li class="news">4:24 AM Sat, Jan. 21st</li>
            <li class="news">
            
            <a href="/weather/">Weather &nbsp;40.0° <img src="http://westernnews.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/images/weather/small/cloudy.gif" height="15" width="15" alt="weather icon"></a>
            
            </li>
            
              <li class="news"><a href="/contact/">News Tips - Contact Editor</a></li>
            
            
          </ul>
        
        
      
      
    <div class="social-media">
      <ul>
        <li><a href="https://www.facebook.com/dailyminer/"> <i class="fa fa-facebook-official sm" aria-hidden="true"></i></a></li>
        <li><a href="https://twitter.com/dailyminer"> <i class="fa fa-twitter-square sm" aria-hidden="true"></i></a></li>
        <li><a href="https://www.youtube.com/user/KingmanDailyMiner"> <i class="fa fa-youtube-square sm" aria-hidden="true"></i></a></li>
        <li><a href="/rss/headlines/"> <i class="fa fa-rss-square sm" aria-hidden="true"></i></a></li>
      </ul>
    </div>
  
        
          <ul class="user">
            
              <li><a href="/accounts/login/?next=/news/2017/jan/20/just-shake-my-head-and-move/">Sign in</a></li>
            
          </ul>
        
      
    </div>
  </div>
  
  
  <div id="header" class="cvr">
    <div class="wrapper">
      
        <div class="branding">
          <h1><a href="/">Kingman Daily Miner</a></h1>
          <p><a href="#body">Jump to content</a></p>
        </div>
        
          <div id="head_search" class="search">
            <form action="/search/" method="get" class="search_form" autocomplete="off">
              <p class="query"><input type="text" name="q" value="" placeholder=" Search"><i id="spy_search" class="fa fa-search" aria-hidden="true"></i></p>
            </form>
          </div>
        
      
    </div>
  </div>
  
  
<div id="nav">
    <div class="wrapper">
        
        <ul>
            
            <li><a href="/"><img class="nav_bar_ball" src="http://westernnews.media.clients.ellingtoncms.com/static/custom/kdminer/logos/nav_bar.png" alt="navigation logo"/></a></li>
            
            <li><a href="/news/news/">News</a>
              <ul>
                <li><a href="/news/news/local/">Local</a></li>
                <li><a href="/news/news/golden-valley-news/">Golden Valley News</a></li>
                <li><a href="/news/news/mohave-911-most-wanted/">Mohave 911 &amp Most Wanted</a></li>
              </ul>
            </li>
              
             <li><a href="/news/opinion/">Opinion</a>
                <ul>
                    <li><a href="/news/opinion/editorials/">Editorials</a></li>
                    <li><a href="/news/opinion/letters/">Letters</a></li>
                    <li><a href="/news/opinion/columns/">Columns</a></li>
                      <ul style="width:auto; left:85px;">
                        <li><a href="/news/blogs/beyond-mainstream-media">Beyond Mainstream Media</a></li>
                        <li><a href="/news/blogs/butchs-brew">Butch's Brew</a></li>
                        <li><a href="/news/blogs/keeping-it-straight">Keeping it straight</a></li>
                        <li><a href="/news/blogs/older-than-dirt">Older than dirt</a></li>
                      </ul>
                    </li>
                </ul>
            </li>
            <li><a href="/news/sports/">Sports</a>
              <ul>
                <li><a href="/news/sports/kingman-academy-high-school/">Kingman Academy High School</a></li>
                <li><a href="/news/sports/kingman-high-school/">Kingman High School </a></li>
                <li><a href="/news/sports/lee-williams-high-school/">Lee Williams High School</a></li>
              </ul>
            </li>
             
            <li><a href="/news/features/">Features</a>
                <ul>
                  <li><a href="/blogs/">Blogs</a>
                  <li><a href="/news/features/out-about/">Out &amp; About</a></li>
                </ul>
            </li>
            <li><a href="/news/milestones/">Milestones</a></li>
            <li><a href="/news/obituaries/">Obituaries</a></li>
            <li><a href="/classifieds/">Classifieds</a></li>
            <li><a href="#">More</a>
                <ul class='double-column'>
                  <li><a target="_blank" href="http://www.928medialab.com">928 Media Lab</a></li>
                  <li><a  href="/pre-website-archives/">Archives: Pre-Web</a></li>
                  <li><a href="/events/">Event Calendar</a></li>          
                  <li><a  href="/users/newsletters/">Join Newsletter</a></li>
                  <li><a  href="/other-publications/">Other Publications</a></li>
                  <li><a  href="/photos/galleries/">Photo Galleries</a></li>
                  <li><a  href="https://classifiedsplacement.westernnews.com/kdminerui814/WFCategoryClassification.aspx" target="_blank">Place an Ad</a></li>
                  <li><a  href="/classifieds/category/public-notices/">Public Notices</a></li>
                  <li><a  href="http://www.kingmanrealestatesearch.com/">Real Estate Search</a></li>
                  <li><a  href="/submit/">Submissions</a></li>
                  <li><a  href="/subscriber-services/">Subscriber Services (Start / Stop)</a></li>
                  <li><a target="_blank" href="http://www.circularhub.com/?p=kdm#!">This Week's Circulars (Flipp)</a></li>
                  <li><a  href="/organizations/">Organizations</a></li>
                  <li><a  href="/videos/">Videos</a></li>
                  <li><a  href="/places/churches/all/">Worship Directory</a></li>
                </ul>
            </li> 
            <li class="float_right"><a  href="/contact-us/">Contact Us</a></li>
        </ul>
        
    </div>
</div>

  
  
  
  <div class="breadcrumbs">
    
  </div>
  
  <div id="body">
    <div class="wrapper">
      
        
        
        
        
          <div class="content_title">
            
  <div id="target-story_headline_template">
  
    <h2 class="header">Just shake my head and move on</h2>
    
  
  </div>

          </div>
        
        
        
        
          
          <div class="content">
            
            
              
                
              
            
            


    
      
          
            <script>
            var re = /(?!.*\/).*/i;
            var category = '[News] /Features'.match(re)[0];
            dataLayer.push({
              'contentGroup1': category,
              'dimension1': category
            });
            </script>
          
      
    
      
    


  
    
    <div class="story_lead_photo">
      <div class="photo">
        
        <a href="/photos/2016/aug/13/38017/"><img src="http://westernnews.media.clients.ellingtoncms.com/img/photos/2016/08/26/KDM-Linda-Varon-older-than-dirt-blog-thumbnail_t715.jpg?529764a1de2bdd0f74a9fb4f856b01a9d617b3e9" alt=""></a>
        
      </div>
      
      <p class="caption">
        
      </p>
    </div>
    
  
  <div class="content_info">
    
    <p class="byline">By <a href="/staff/linda-varon/">Linda Varon</a></p>
    <li class="datetime">Originally Published: January 20, 2017 6:07 p.m.</li>
    <br>
    <div class="share_story">
      <ul>
        <li><div class="fb-share-button" data-layout="button" data-size="small" data-mobile-iframe="true"><a class="fb-xfbml-parse-ignore" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u&amp;src=sdkpreparse">Share</a></div></li>
        <li id="twit"><a href="https://twitter.com/share" class="twitter-share-button" data-text="Check out this story" data-via="WniTest">Tweet</a>
        <script async>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs'); </script></li>
        <li><i class="fa fa-print"></i></li>
        <li><a href="mailto:?subject=Just shake my head and move on&body=http://kdminer.com/news/2017/jan/20/just-shake-my-head-and-move/"><i class="fa fa-envelope-o"></i></a></li>
      </ul>
    </div>
    
      <li class="datetime" style="list-style:none;">
        <a href="/news/2017/jan/20/just-shake-my-head-and-move/">
          
        </a>
      </li>
    
    <div class="section_social">
      
      <ul class="social-networks">
        
      </ul>
      
    </div>
  </div>
  
  <div class="story_body" id="target-story_body_template">
    <p>Sometimes we just have to shake our head and move on. I don't expect everyone to understand everything, but can't we at least expect SOME common sense? </p>

<p>I recently took one of my dogs for his monthly toenail trim. I like to use the vet apposed to a groomer. I have had a few bad experiences with dog groomers. My choice and nothing against groomers. As it turned out, my old dog was injured during the visit. He is 13 years old, and his joints are not in the best condition. Anyway, I ended up needing to get an anti-inflammatory medication for him. I asked the veterinarian to please call in the medication to a pharmacy that I know fills animal prescriptions. They are much cheaper than what the doctor’s office charges.</p>

<p>Having dealt with this pharmacy in the past, I knew it was best to call first and make sure the medicine was called in before trying to pick it up. I was assured that it was ready and could be picked up. I was also happy that it was only $5.03. So, there I am at the counter. I tell them MY name and that the prescription would be for my dog, TIMMY. "I have nothing here for you or Timmy." I said, “I already called and someone here said you DO have it." "What is the birth date?" she said. "Mine or Timmy's?" I asked. "Let's try both" was her suggestion. Again, I was told she had nothing. I suggested she try checking under the name of the veterinarian. Whoopee! Finally found it.</p><div id='story_inline_ad'><!-- /132810331/dm_ict --><div id='div-gpt-ad-1478905854152-0' style='height:600px; width:160px;'><script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1478905854152-0'); });</script></div></div>

<p>It turned out that the doctor had given the wrong birth date for Timmy, my dog. I guess it was just easier to say, "We have no medication called in for you."</p>

<p>Ever have one of those days that it seems anything that you try to do has some kind of glitch? It can start with running out of coffee when you are ready to make that needed eye-opener in the morning. Myself, I would never let that happen. I might run out of many things, but toilet tissue or coffee, never gonna happen.It could start with finding that one of the dogs has left you a package in a corner. You may discover it after you have already stepped in it. Why is it so darn hard to clean dog poop off the bottom of a slipper? Maybe you left a couple of small throw rugs to dry outside. It sure didn't LOOK like rain. It is a lot like spending an hour sweeping up all the leaves from your front patio, and then twenty minutes later you see that the wind has blown a thousand more leaves in, from the neighbors who were obviously smart enough to wait on the sweeping.</p>

<p>How about when you finally decide to hang up those framed photos you have had stuck in the closet since you last moved. (Yes, it could be over two years. I don't judge.) You are careful to find the perfect-sized nail to accommodate what you are going to hang. You put the picture up and step back to look at your work. Low and behold, it is crooked! I can't live with crooked! So, you decide to start over. During this process, you drop the nail on the floor. Even with a flashlight, you are unable to find the nail! You immediately decide that if you don't find it, one of your dogs will step on it and it will go directly into their foot. After twenty minutes, you finally give up and just pray for the dogs.</p>

<p>I can't be the only one who gets all the upsetting mail on Saturday. You know the kind I mean. The insurance company mail that says you owe much more than you KNOW that you owe? Or the one that says they "did not receive your payment" and you know that is crap! Or your electric bill shows up and it is twice what you figured it would be. I have to wonder how they do it? How do they know exactly when to mail it that will have it show up on Saturday? Thus allowing you to stew about it until Monday, when you probably can't get through on the phone anyway.</p>

<p>OK. Who has NOT ever left the front door key in the lock? You are bringing in a bunch of groceries, and manage to open the door without having to set bags on the ground. You shut the door behind you and hurry to get the freezer stuff put away. After everything is put where it belongs you take a few minutes to relax and are glad that is over with for a week. When you go to bed that night you check that the front door is secured to insure that no one can come in and harm you. When you go out in the morning to pick up your morning paper, guess what? Your house key is securely hanging from the lock! An invitation to enter without breaking in. And yet, you slept like a baby, knowing you were all safe and sound.</p>

<p>I was recently shopping at a retail store here in town for a new outfit for my birthday. I was happy to find just the outfit I wanted. I looked for a check out that had less than ten people in line. I assured the person who took me shopping that I would get in and out quick. Once again I had one of those little glitches. The cash register in MY line had a problem with its computer. Everyone in line was asked to step into yet another line. As the person at the head of the line got his items totaled up, this register ALSO had a problem with the computer. When we were asked to move again, I had about had enough! Does it not occur to anyone yet that the registers all work from the SAME computer system? Hello!</p>

<p>Filling up pill containers can be another test of patience. Especially if any of your medications include tiny pills. When your hands are the size of boxing gloves, close work is always a challenge to begin with. You have all the medicines in a large box. You put the box with the bottles on the kitchen table. I personally have not only my medications, but Sister's as well. I line up the weekly morning/evening containers and I am ready. I have been doing this for so long, it SHOULD be easy. Not! If I don't knock at least one of the filled containers over, I am almost guaranteed to drop at least one pill on the floor! This can often put me into panic mode. Again, I not only have two tiny dogs that one of which will eat ANYTHING off the floor, but a two-year-old great-granddaughter who cannot be totally trusted yet. If I have done this once, I have done it ten times. I look for the pill that I have dropped. I know it hit the floor, because I heard it. How does it bounce and end up in another room all together? I have had occasion to ask my neighbor who has much better eyes than I to please come and help me look for the pill.</p>

<p>These are just a few of the things that I experience on a fairly regular basis. Please tell me I am not the only one who has days when NOTHING goes as planned. It is these little glitches that make some people drink wine, I think.</p>

<p>As for yours truly, I just shake my head and move on..</p>
    
    
  </div>
  
  
  




  <ul class="object_tools" style="border-bottom:none; border-top:1px solid #eee; padding:10px 0 0 0;">
    
      
        
        <li class="favorite">
          
            <a href="/accounts/login/?next=/news/2017/jan/20/just-shake-my-head-and-move/">Sign in to favorite this</a>
          
        </li>
        
      
      
      
        <li class="comment">
          <a href="#comments">Discuss</a>
          <small>
            <a href="#comments">Comment</a>
          </small>
        </li>
      
        
    
  </ul>

      <script>
        $(document).ready(function(){
          $('#print_btn').bind('click', function(){
            window.print();
          })
        })
      </script>
  
  <div class="recommended">
    <h3>More like this story</h3>
    <ul>
      
      <li><a href="/news/2016/may/05/older-than-dirt-room-for-one-more/">Older Than Dirt:  Room for one more?</a></li>
      
      <li><a href="/news/2016/aug/06/its-all-rage/">It&#39;s all the Rage</a></li>
      
      <li><a href="/news/2014/nov/07/groomer-adds-shop-to-growing-number-of-downtown-b/">Groomer adds shop to growing number of downtown businesses</a></li>
      
      <li><a href="/news/2013/jan/02/young-man-gets-the-gift-of-hunting/">Young man gets the gift of hunting</a></li>
      
      <li><a href="/news/2008/oct/29/letter-we-cant-let-this-continue/">Letter: We can&#39;t let this continue</a></li>
      
    </ul>
  </div>
  

    
  <h3 class="sign_in "><a href="/accounts/login/?next=/news/2017/jan/20/just-shake-my-head-and-move/">Sign in to comment</a></h3>
  

  

  
    

<div id="comments">
    

    
    
    
    
    
    
    
<h3 class="header">Comments</h3>
<h5>Comments are not posted immediately. Submissions must adhere to our Use of Service <a href="/terms-of-service/">Terms of Use</a> agreement. Rambling or nonsensical comments may not be posted. <span style="color:red;">Comment submissions may not exceed a 200 word limit, and in order for us to reasonably manage this feature we may limit excessive comment entries.</span></h5>

  <p class="no_comments">Use the comment form below to begin a discussion about this content.</p>

    
    
    

    
    

    
    
    
    
    









  

  




    
    
    
</div>

  



            
              
                
              
            
          </div>
        
        

    
      
          
            
<div class="sidebar">
  <!-- /132810331/dm_rr_1 -->
<div id='div-gpt-ad-1469119880082-9' style='margin:0 auto; text-align:center;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469119880082-9'); });
</script>
</div>
  <br>
<!-- /132810331/dm_rr_2 -->
<div id='div-gpt-ad-1469119880082-10' style='margin:0 auto; text-align:center;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469119880082-10'); });
</script>
</div>
  <br>
  <br>
<!-- /132810331/dm_rr_3 -->
<div id='div-gpt-ad-1469119880082-11' style='margin:0 auto; text-align:center;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469119880082-11'); });
</script>
</div>
    
      <div id="circularhub_module_2887" class="flipp_ad"></div>
<script src="//api.circularhub.com/2887/8220cfa17162bb18/flyertown_module.js"></script>
    
   <div id="most_read_sidebar" class="section section_end"> 
    

  <div class="tabs">
   <div class="most_read"><i class="fa fa-line-chart"></i><span>MOST READ</span></div>
    <!-- Radio button and lable for #tab-content1 -->
    <input type="radio" name="tabs" id="tab1" checked >
    <label for="tab1">
      <i class="fa fa-calendar"></i><span>7 days</span>
    </label>
    <!-- Radio button and lable for #tab-content2 -->
    <input type="radio" name="tabs" id="tab2">
    <label for="tab2">
      <i class="fa fa-calendar"></i><span>30 days</span>
    </label>

    <ul id="tab-content1"class="tab-content">
		<li><a href="/news/2017/jan/18/trooper-rescues-teenage-victim-sex-traffickers/">Trooper rescues teenage victim from sex traffickers </a></li>
		<li><a href="/news/2017/jan/14/sid-cranstons-alleged-murderer-remanded-without-bo/">Sid Cranston’s alleged murderer remanded without bond </a></li>
		<li><a href="/news/2017/jan/17/kpd-seeks-man-who-allegdly-shot-kingman-teenager/">KPD seeks man who allegdly shot Kingman teenager </a></li>
		<li><a href="/news/2017/jan/18/woman-killed-train-jan-10-identified/">Woman killed by train Jan. 10 identified </a></li>
		<li><a href="/news/2017/jan/16/kpd-man-spit-officer/">KPD: Man spit on officer </a></li>
		<li><a href="/news/2017/jan/16/traffic-stop-yields-half-pound-meth/">Traffic stop yields half pound of meth </a></li>
		<li><a href="/news/2017/jan/18/obituary-linda-brooks/">Obituary: Linda Brooks </a></li>
		<li><a href="/news/2017/jan/20/obituary-daniel-danny-callahan/">Obituary: Daniel 'Danny' Callahan </a></li>
		<li><a href="/news/2017/jan/13/meadview-man-charged-attempted-murder/">Meadview man charged with attempted murder </a></li>
		<li><a href="/news/2017/jan/16/mohave-911-jan-16-2017/">Mohave 911: Jan. 16, 2017 </a></li>
</ul>
    <ul id="tab-content2"class="tab-content">
		<li><a href="/news/2017/jan/10/kpd-remains-missing-real-estate-agent-possibly-fou/">KPD: Remains of missing real estate agent possibly found </a></li>
		<li><a href="/news/2017/jan/04/kingman-man-arrested-manslaughter-after-child-dies/">Kingman man arrested for manslaughter after child dies in crash </a></li>
		<li><a href="/news/2016/dec/23/several-stores-will-be-open-christmas-and-heres-wh/">Several stores will be open on Christmas - and here's why </a></li>
		<li><a href="/news/2017/jan/10/body-found-near-train-tracks/">Body found near train tracks </a></li>
		<li><a href="/news/2017/jan/18/trooper-rescues-teenage-victim-sex-traffickers/">Trooper rescues teenage victim from sex traffickers </a></li>
		<li><a href="/news/2017/jan/14/sid-cranstons-alleged-murderer-remanded-without-bo/">Sid Cranston’s alleged murderer remanded without bond </a></li>
		<li><a href="/news/2017/jan/06/suspicious-explosion-rocks-butler-area/">Suspicious explosion rocks Butler area </a></li>
		<li><a href="/news/2017/jan/12/sid-cranstons-family-ready-start-healing-process/">Sid Cranston’s family ready to start the healing process </a></li>
		<li><a href="/news/2017/jan/11/kpd-fbi-arrests-sidney-cranstons-alleged-killer/">KPD: FBI arrests Sidney Cranston's alleged killer </a></li>
		<li><a href="/news/2016/dec/27/golden-valley-dispute-leads-one-dead/">Golden Valley dispute leads to one dead </a></li>
</ul>

  </div>

  </div>
   
  <div id="top-stories" class="sidebar-feature">
  
  
    
    </div>
    
</div>
          
      
    
      
    


      
    </div>
  </div>
  
<!-- /132810331/dm_lb_btf -->
<div id='div-gpt-ad-1478281167011-1' style="display:block; margin:0 auto; text-align:center;">
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1478281167011-1'); });
</script>
</div>

  
   
  
<div id="dc_footer">
    <div class="wrapper">
      <div class="f_sections logo_search">
        <div class="search_form">
            <form action="/search/" method="get" class="search_form" autocomplete="off">
              <input type="text" name="q" value="" placeholder=" Search">
            </form>
        </div>
           <div class="footer_logo">
            
            <img src="http://westernnews.media.clients.ellingtoncms.com/static/custom/kdminer/logos/footer-logo.png" />
            
          </div>
      </div>
      <div class="f_sections">
       <ul>
        <li>SECTIONS</li>
        <li><a href="/news/news/">News</a></li>
        <li><a href="/news/opinion/">Opinion</a></li>
        <li><a href="/news/sports/">Sports</a></li>
        <li><a href="/news/features/">Features</a></li>
        <li><a href="/news/milestones/">Milestones</a></li>
        <li><a href="/news/obituaries/">Obituaries</a></li>
       </ul>
      </div>
      <div class="f_sections">
       <ul>
        <li>CLASSIFIEDS</li>
        <li><a href="/classifieds/">Main</a></li>
        <li><a href="/classifieds/category/employment/">Jobs</a></li>
        <li><a href="/classifieds/category/automobiles/">Cars</a></li>
        <li><a  href="https://classifiedsplacement.westernnews.com/kdminerui814/WFCategoryClassification.aspx" target="_blank">Place an Ad</a></li>
        <li><a href="/contact/">Contact Us</a></li>
        <li><a href="http://kdminer.com/documents/2015/aug/01/kingman-daily-miner-advertising-rates-information/">Ad Rates</a></li>
       </ul>
      </div>
      <div class="f_sections">
       <ul>
        <li>EVENTS</li>
        <li><a href="/events/">Today's Events</a></li>
        <li><a href="/news/milestones/births/">Births</a></li>
        <li><a href="/news/milestones/couples/">Wedding </br> Engagement</a></li>
        <li><a href="/events/search/">Search Events</a></li>
        <li><a href="/events/submit/">Submit Event</a></li>
       </ul></div>
      <div class="f_sections">
       <ul>
        <li>SUBMISSIONS</li>
        <li><a href="/contact/">Submit a News Tip</a></li>
        <li><a href="/submit/birth-announcement/">Birth</a></li>
        <li><a href="/submit/engagement-wedding-announcement/">Wedding </br> Engagement</a></li>
        <li><a href="/submit/anniversary/">Anniversary</a></li>
        <li><a href="/contact/">Website Feedback</a></li>
        <li><a href="/subscriber-services/">Subscriber Services</a></li>
       </ul>
      </div>
      <div class="f_sections">
       <ul>
        <li>PROFILE</li>
        
        <li><a href="/accounts/login/">Sign In</a></li>
        
        <li><a href="/users/newsletters/">Newsletter</a></li>
       </ul>
      </div>
    </div>
    <div class='copyright'>
       
         <p class="copy_contents"><span id="unlink">Contents of this site are &copy; Copyright 2017 Kingman Daily Miner and Western News &amp; Info&reg;, Inc. All rights reserved. | </span><a href="/terms-of-service/" > Terms of Service</a> | <a href="/privacy-policy/" >Privacy Policy</a></p>
       
    </div>
  </div>


</div>
  <script type="text/javascript" src="http://westernnews.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/javascript/thirdparty/wmd.min.js" async></script>
  <script type="text/javascript" src="http://westernnews.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/javascript/onload.min.js" async></script>
  
<script>
$(document).ready(function(){
  $('#page').find('.fa-print').bind('click', function(){
      window.print();
    });
  });
</script>
<script>
  $(window).load(function(){
    $("iframe[id^='twitter-widget']").addClass('twitter_margin');
});
</script>

  <script type="text/javascript" src="http://westernnews.media.clients.ellingtoncms.com/static/ellington_defaults/2.3.0/javascript/thirdparty/jquery.ui.js" async></script>
  <script>
     // turn plain text links into hyperlinks
    $('p').linkify();
    $('#sidebar').linkify({
      target: "_blank"
    });
  </script>

<script type="text/javascript" src="http://westernnews.media.clients.ellingtoncms.com/static/javascript/word_limit.js?v=7" ></script>
 <script type="text/javascript" src="http://westernnews.media.clients.ellingtoncms.com/static/javascript/westernnews.js?v=14" async></script>
</body>
</html>
